Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Linux Forum Linux-Web.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

12.06.2005, 20:19

1000 HZ + Preempt + LowLatency + Kernel 2.4.29

Hi

Hab da ne Frage habe seid 2 Wochen einen Rootserver gemietet um mich mit Linux usw besser vertraut zu machen. Nebenbei wollte ich einen Gameserver betreiben.( Latence mässig sollte er natürlich sehr gering sein). Deshalb hab ich viel gegoogelt und diese Lösung sollte nach mehreren Aussagen perfect sein.

-->1000 HZ + Preempt + LowLatency + Kernel 2.4.29

(Mein System) Debian 3.1 Sarge Kernel 2.6.8

Den Kernel wollte ich erst patchen aber dann hab ich gesehen das man den auch per

apt-get install kernel-source-2.4.29 bekommen kann. Also hab ich das mal gemacht. Nur wenn ich uname -a eingebe zeigt er mir immer noch den alten bzw neueren 2.6.8 Kernel an.

Nach einigen Anleitungen im Netz kann man das irgendwie mit Lilo umändern. Nur wie geht das? (Beim 2.6.11 gabs dazu ne Anleitung hat irgendwie funktioniert aber beim 2ten Versuch gings dann schon nicht mehr.)

So nächster Punkt

die beiden anderen Patche kann man auch per

apt-get install kernel-patch-2.4-lowlatency kernel-patch-2.4-preempt

installieren. Nur muss man da sonst noch etwas machen damit die laufen oder ist das alles?

So als letztes was ich überall gesehen habe aber irgendwie nirgends so erklärt wurde das ich das auch kapiert habe is dieses 1000 HZ patch beim 2.6.11 kernel hat das super funktioniert man konnte den Wert dann manuell abändern und fertig wars. Nur hier geht das anscheinend ohne Patch nicht. Auch beim suchen hab ich den patch nur Ansatzweise hier gefunden weiss aber auch nicht ob das der richtige ist. -->

http://www.plumlocosoft.com/kernel/patch…14-vhz.diff.bz2

Und nächstest Prob ist dann auch noch wie installier ich das Teil?

saugen ist klar entpacken auch nur wie installier ich den patch per patch -p1 -i?

Wenn mir da einer eine kleine Befehl combo psoeten würde wäre ich ihm sehr Dankbar.

THX

P.S. Eure Smilies sind voll abgedreht hehe :blume2: :applaus: :schlumpf: :banane:

mfg

Andy

Thema bewerten