Sie sind nicht angemeldet.

1

07.12.2014, 22:36

Debian - Mopidy spielt keinen Sound im Browser oder über MPD App ab

Hallo zusammen,

ich bin neu im Forum und hoffe, dass ich meinen Thread richtig einsortiert habe ;)

Nun aber zum Thema: ich habe eine VM mit Debian aufgesetzt und den Musikserver Mopidy darauf installiert und konfiguriert. Leider spielt dieser keine Musik ab, beziehungsweise höre ich keine Musik obwohl sie abgespielt wird. Ich habe während der Durchführung alle Schritte dokumentiert. Die Dokumentation könnt ihr euch als pdf hier herunterladen (war leider zu groß für einen Dateianhang).

Weiß jemand vielleicht, was ich falsch gemacht habe, beziehungsweise übersehen habe?

Vielen Dank im Voraus :)

Grüße

Yannik

jürgen

Schüler

  • »jürgen« ist männlich

Beiträge: 71

Wohnort: Zehdenick

Beruf: Agraringenieur

  • Nachricht senden

2

10.01.2015, 22:18

Hallo,

starte die Programme in der Konsole oder Terminal und achte auf Fehlermeldungen
programmname -v

LG

3

13.01.2015, 15:01

Hallo jürgen,

vielen Dank für den Tipp. Ich habe deinen Tipp befolgt. Einen Fehler kann ich allerdings nicht finden. Habe den Log mal angehängt. Hab ich etwas übersehen?

Skripts werden ebenfalls keine blockiert und der Wechsel des Browsers brachte auch nichts.

Hat jemand noch weitere Lösungsvorschlage?

Vielen Dank im Voraus.
»YannikT« hat folgende Datei angehängt:

jürgen

Schüler

  • »jürgen« ist männlich

Beiträge: 71

Wohnort: Zehdenick

Beruf: Agraringenieur

  • Nachricht senden

4

14.01.2015, 13:58

Hallo,

es läuft eine Virtuelle Maschine mit Debian ?
Welche Systeme mit welchem Kernel werden verwendet,
welcher Desktop mit welchem Mixer wird verwendet ?

LG

5

16.01.2015, 14:20

Hallo jürgen,

das Host-Betriebssystem ist Windows 8.1 Pro mit der Virtualisierungsumgebung Hyper-V. Auf der virtuellen Maschine (Generation 1) läuft Debian 7.7.0 wheezy mit dem Linux Kernel 3.2, die Desktop Oberfläche ist Gnome in der Version 3.4.2.
Folgendes zeigt mir Putty beim Login über SSH an: Linux MopidyDEB 3.2.0-4-amd64 #1 SMP Debian 3.2.65-1 x86_64.
Soweit ich das erkenne wird der Mixer "pulseaudio" verwendet.

Sind die Informationen soweit ausreichend?

Vielen Dank im Voraus.

jürgen

Schüler

  • »jürgen« ist männlich

Beiträge: 71

Wohnort: Zehdenick

Beruf: Agraringenieur

  • Nachricht senden

6

16.01.2015, 19:34

Hallo,

ich bin fast sicher, daß der der Kernel - wheezy die Ursache für Dein Problem ist

mpoidy ist nur für jessie oder debian sid verfügbar.

Abhilfe
eine Neuinstallation mit Debian Jessie = debian testing
oder mit Debian Sid = debian unstable

oder das aktuelle Debian Wheezy auf Jessie updaten,
dazu als Root im Verzeichnisbaum die /etc/apt/sources.list bearbeiten
ein Terminal öffnen
su
nach Abfrage das Passswort von Root eingeben
gedit das ist der gnome texteditor
im Verzeichnisbaum /etc/apt/
die sources.list öffnen
alle wheezy Einträge mit jessie ersetzen und abspeichern
danach immer noch als root im terminal
apt-get update und anschließend
apt-get dist-upgrade -d

damit werden alle nötigen Pakete zum Upgraden heruntergeladen (ich schätze 500 - 800 mb)

das eigentliche Upgrade muß ohne Grafik erfolgen

von Gnome abmelden - nicht runterfahren
alt+F1 oder alt+F2 wechselt auf die Konsole (es gibt 6 Konsolen, alt+F7 wechselt wieder zur Grafik))
als root anmelden - Paßwort eingeben

init 3 beendet den Grafikmodus
apt-get dist-upgrade
aktualisiert das System, (dabei werden immer wieder einige Sachen abgefragt)
falls es Fehler gibt
apt-get -f Install hilft bei fehlenden Abhängigkeiten
wenn alles geklappt hat
Neustart, da ein neuer Kernel installiert wurde

apt-get clean löscht die heruntergeladenen Dateien vom Systemupgrade

LG

7

26.01.2015, 16:08

Hallo,

ich habe das Update nach deiner Anleitung durchgeführt. Er zeigt mit mit dem Befehl "uname -a" folgendes an:
"Linux MopidyDEB 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt2-1 (2014-12-08) x86_64 GNU/Linux"

Der Befehl "cat /proc/version" liefert folgendes zurück:
"Linux version 3.16.0-4-amd64 (debian-kernel@lists.debian.org) (gcc version 4.8.3 (Debian 4.8.3-16) ) #1 SMP Debian 3.16.7-ckt2-1 (2014-12-08)"

Stimmt das soweit?
Leider wird immer noch kein Sound abgespielt. Beim start von Mopidy kam folgende Fehlermeldung:
"(gst-plugin-scanner:1685): Clutter-CRITICAL **: Unable to initialize Clutter: Unable to open display. You have to set the DISPLAY environment variable, or use the --display command line argument"
Ich habe mich nach dem Update bisher nur mit Putty über SSH aufgeschaltet.

Hat eventuell noch jemand Vorschläge, wie man das Problem lösen könnte?

EDIT: Nach Reconnect und erneutem Starten von Mopidy kam diese Fehlermeldung nicht mehr.

jürgen

Schüler

  • »jürgen« ist männlich

Beiträge: 71

Wohnort: Zehdenick

Beruf: Agraringenieur

  • Nachricht senden

8

28.01.2015, 20:30

Dir fehlen gstreamer Bilbliotheken
im terminal oder konsole

Programmsuche
apt-cache search gst-plugins
apt-cache search gstreamer

danach die Installation
apt-get install programmname
falls die Pakete schon installiert sind, gibt es eine entsprechende Info

eventuell fehlen noch
lame, twolame

LG

Thema bewerten