Sie sind nicht angemeldet.

1

29.12.2009, 18:31

Boot-CD mit Isolinux

Hallo Liebe Forengemeinde!!!


Ich wollte nun einen kleinen Einstieg in Linux - Boot CD's machen und fand hier für folgendes Tutorial:

http://www.linuxroute.de/howto/isolinux_bootcd.php

Die Anleitung hab ich Schritt für Schritt durchgearbeitet und die Dateien zusammengestellt. Das .iso, habe ich nun versucht mit VirtualBox zu mounten und folgender Text bekomme ich zu sehen:

Zitat


boot:
Da drücke ich Enter... er rackert die ganzen Aufgaben durch bis zu:


Zitat


Begin: Waiting for root file system ... ...

Done. Gave up waiting for root device. Common problems:
- Boot args (cat /proc/cmdline)
- check root delay
- check root=
- Missing modules (cat /proc/modules)
ALERT! /dev/sda3 does not exist. Dropping to a shell!


Dann kommt die BusyBox.


Mir ist klar dass es wohl in der isolinux.cfg an folgender Zeile happert:

Zitat

append root=/dev/sda3 initrd=/linux/initrd.img load_ramdisk=1 prompt_ramdisk=0 ramdisk_size=6464



Auf dem Ubuntu, von dem ich die System.map, kernel etc. gezogen habe:

Zitat


mount
/dev/loop0 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type tmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
/dev/sda3 on /host type fuseblk (rw)


=> Daher dachte ich, dass ich wohl /dev/sda3 als Parameter angeben muss?


Habe ich etwas falsch verstanden?
Ich danke Euch für Eure Hilfen und dass Ihr mir ein bisschen Licht in die Sache bringt :)

2

29.12.2009, 21:04

RE: Boot-CD mit Isolinux

Du mußt die root-partition angeben!
Im Grunde sind es immer die Verbindungen mit Menschen, die dem Leben seinen Wert geben. (Wilhelm von Humboldt)

3

30.12.2009, 00:28

Du hast im 3. Zitat die root=device ja angegeben.

Sie wird aber nicht gefunden.

Versuche erst einmal /dev/hda3. Dennn bei 2.6.27 wurde der Kernel geändert und verschiedene Sachen die danach sda waren, waren davor hda. Ab 2.6.33 wurden sie wieder geaendert, usb-Sachen heissen jetzt /dev/uba usw. Was fuer eine kernel-Version hast du denn ?

Normalerweise wird auch mehr ausgegeben - naemlich diejenigen Partitionen die gefunden wurden (wobei fuer root aber eine andere verlangt und daher nicht gebootet wurde). Falls das der Fall ist, sieh dir die Liste genau an, wie da die root-device heißt.

Ausserdem, sind im Kernel alle Datei-Systeme compiliert ? Wenn nicht, mußt du jedenfalls eine initrd nehmen, WO DIESE MODULE (zBsp fuer ext3) DRAUF SEIN MUESSEN. Und zwar genau fuer den Kernel den du zum booten nimmst

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »wl59« (30.12.2009, 00:30)


4

30.12.2009, 08:10

Bei Boot-CDs ist das ein bisshen doof, weil man i.d.R. gar nicht wissen kann, auf welchem Device das root-Dateisystem liegt.
Um das zu umgehen, kann man entweder ggf. eine UUID benutzen oder das root-file-system muss anders dynamisch ermittelt werden.

5

30.12.2009, 09:15

Zitat

Original von wl59
Du hast im 3. Zitat die root=device ja angegeben.

Sie wird aber nicht gefunden.

Genau, das dachte ich mir.

Zitat

Original von wl59
Versuche erst einmal /dev/hda3. Dennn bei 2.6.27 wurde der Kernel geändert und verschiedene Sachen die danach sda waren, waren davor hda. Ab 2.6.33 wurden sie wieder geaendert, usb-Sachen heissen jetzt /dev/uba usw.

Habe ich gerade versucht. Kein Erfolg

Zitat

Original von wl59
Was fuer eine kernel-Version hast du denn ?

2.6.31-16-generic

Zitat

Original von wl59
Normalerweise wird auch mehr ausgegeben - naemlich diejenigen Partitionen die gefunden wurden (wobei fuer root aber eine andere verlangt und daher nicht gebootet wurde). Falls das der Fall ist, sieh dir die Liste genau an, wie da die root-device heißt.

Nein, leider wird nicht mehr ausgegeben. Muss ich vll irgendwo ein verbose Flag reinmachen?

Zitat

Original von wl59
Ausserdem, sind im Kernel alle Datei-Systeme compiliert ? Wenn nicht, mußt du jedenfalls eine initrd nehmen, WO DIESE MODULE (zBsp fuer ext3) DRAUF SEIN MUESSEN. Und zwar genau fuer den Kernel den du zum booten nimmst

Ja, hab das initrd laut Anleitung genommen von dem Kernel auf dem ich arbeite und auch der Rest stammt.


Zitat


Bei Boot-CDs ist das ein bisshen doof, weil man i.d.R. gar nicht wissen kann, auf welchem Device das root-Dateisystem liegt.

Genau mein Problem. Ich würde die CD gerne in eine beliebige Box stecken, so dass sie auch bootet und ausgeführt wird.

Zitat


Um das zu umgehen, kann man entweder ggf. eine UUID benutzen oder das root-file-system muss anders dynamisch ermittelt werden.

An so einen Ansatz dachte ich schon, aber das Verfahren mit der UUID ist mir unbekannt, und wie man es dynamisch ermittelt da bin ich mir nicht sicher. Kannst du mir hier ein paar Beispeile geben?


Vielen Dank für die schnelle Hilfen!

6

30.12.2009, 11:42

Wieso weiß er nicht wo die Root-Partition liegt, der hat das System doch eingerichtet. Wenn man den Standardinstallationen folgt i. d. R. im MBR auf /dev/hda1. Zur Not kann man mit fdisk -l nachschauen.
Im Grunde sind es immer die Verbindungen mit Menschen, die dem Leben seinen Wert geben. (Wilhelm von Humboldt)

7

30.12.2009, 16:19

Natürlich!

Zitat


root@ubuntu:~# fdisk -l

Platte /dev/sda: 160.0 GByte, 160041885696 Byte
255 Köpfe, 63 Sektoren/Spuren, 19457 Zylinder
Einheiten = Zylinder von 16065 Ã 512 = 8225280 Bytes
Disk identifier: 0xf9f5f9f5

Gerät boot. Anfang Ende Blöcke Id System
/dev/sda1 * 1 14337 115161921 7 HPFS/NTFS
/dev/sda2 16250 19457 25768260 f W95 Erw. (LBA)
/dev/sda3 14338 16249 15358140 7 HPFS/NTFS
/dev/sda5 16250 19457 25768228+ 7 HPFS/NTFS

Partitionstabelleneinträge sind nicht in Platten-Reihenfolge


=> Wie ich schon oben gesagt habe /dev/sda3!
Oder seh ich das falsch?

Die Partition für die ich Ubuntu eingerichtet habe, hat 15GB abbekommen, wie man ja bei /dev/sda3 sehen kann.

Zur Überprüfung habe ich folgendes gemacht:

Zitat


root@ubuntu:~# df -h
Dateisystem GröÃe Benut Verf Ben% Eingehängt auf
/dev/loop0 7,5G 2,4G 4,8G 34% /
udev 249M 320K 249M 1% /dev
none 249M 1,5M 248M 1% /dev/shm
none 249M 100K 249M 1% /var/run
none 249M 0 249M 0% /var/lock
none 249M 0 249M 0% /lib/init/rw
/dev/sda3 15G 8,6G 6,1G 59% /host


=> /dev/sda3


Folgender Inhalt in der isolinux.cfg

Zitat


#Linux Boot CD
display message.txt
prompt 1
timeout 100

DEFAULT linux

LABEL linux
SAY Now booting the kernel from SYSLINUX...
KERNEL /linux/vmlinuz
APPEND ro root=/dev/sda3 initrd=/linux/initrd.img


ls -R ./cdroot

Zitat


./cdroot/:
isolinux.bin isolinux.cfg linux message.txt

./cdroot/linux:
initrd.img System.map-2.6.31-14-generic vmlinuz



sollte doch eigentlich alles richtig sein, oder?

8

30.12.2009, 18:37

Auf /dev/sda3 ist gar keine Linux Partition sondern eine Windows Partition

9

30.12.2009, 19:10

boot liegt in /dev/sda1
Im Grunde sind es immer die Verbindungen mit Menschen, die dem Leben seinen Wert geben. (Wilhelm von Humboldt)

10

01.01.2010, 12:41

Also erstmals vielen Dank für alle Informationen.

Habej etzt 2 weitere Tage alles mögliche versucht und noch ohne Erfolg:

Zitat


# Meine Linux Boot-CD
# Den Inhalt von message.txt anzeigen
display message.txt
# Bootpromt anzeigen
prompt 1
# 30 Sekunden auf Eingabe warten
timeout 300
# Wenn keine Eingabe erfolgt, das Defaultlabel booten
default linux

label linux
kernel /linux/vmlinuz
append root=/dev/sda1


Nun bekomm ich beim Booten folgenden Fehler:

Zitat


Cannot open root device /dev/sda1 or unknown block (8,1)
Please append a correct root= boot option; here are the available partitions:
0800: sda driver: sd
0b00: sr0 driver: sr


Habe schon versucht von sda und sr0 zu booten (also als root=/dev/sda und root=/dev/sr0) jedoch ebenfalls ohne Erfolg.

11

01.01.2010, 20:12

Kann mir denn keiner weiterhelfen?

Thema bewerten