Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Linux Forum Linux-Web.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

31.01.2009, 17:10

[gelöst] Festplatte einbinden

Hallo Linux Freunde.

Ich bin ein absoluter Noob.

Mein Problem ist das ich mir einen gebrauchten Optiplex SX270 gekauft habe, ohne CD Laufwerk.

Eine USB-Windoof Installation war nicht möglich.

Jetzt habe ich mir eine USB-Bootfähige Knoppix Version erstellt, alles läuft super, außer das die Festplatte nicht eingebunden werden kann.

Ich habe die Suchfunktion benutzt leider mit negativen ergebniss.

Zum Problem:

Wenn ich auf die Festplatte klicke kommt folgender Fehler:
Laufwerk kann nicht eingebunden werden“
mount: I could not determine the filesystem type, and none was specifed


Die Festplatte ist leer. Kann auch Formatiert werden.

So da ich die Suchfunktion benutzt habe, hier die ersten ergebnisse eurer Fragen.

Fdisk -l (Sorry kann man auch nur den text kopieren?)
http://img101.imageshack.us/img101/717/b…rmphoto1tj4.jpg

Was kann ich Probieren?

Vielen Dank

MFG Popey

strcat

Unix Gladiator

  • »strcat« ist männlich

Beiträge: 2 282

Wohnort: /Earth/Germany/Bavaria/Regensburg

  • Nachricht senden

2

31.01.2009, 18:06

Lies mal die Fehlermeldungen genauer.

linuxerr

Prof. Dr. Schlaumeier

  • »linuxerr« ist männlich

Beiträge: 8 557

Wohnort: Mecklenburg, zur Entwicklungshilfe in Chemnitz/Sachsen ;-)

  • Nachricht senden

3

31.01.2009, 18:57

lösch die win95 partition und leg eine neue an!
Die Rechtschreibfehler in diesem Beitrag sind nicht urheberrechtlich geschützt.
Jeder der einen findet darf ihn behalten und in eigenen Werken weiterverwenden.

4

31.01.2009, 20:31

RE: Festplatte einbinden

Zitat

Original von Popey
(Sorry kann man auch nur den text kopieren?)

Im X genügt es i.d.R., den Text zu markieren und er kommt automatisch in den "Primary Selection"-Puffer. Man kann ihn dann mit der tertiären (mittleren) Maustaste (auch Scrollwheel herunterdrücken oder beide Tasten gleichzeitig, falls nur zwei da sind) oder Shift+Einfügen einfügen.

Darüber hinaus gibt es noch einen (oder mehr) Clipboard- oder Cut-Buffer. Die werden gefüllt, wenn man explizit die Kopieren- oder Ausschneiden-Funktion eines Programms benutzt. Mit Programmen wie xclipboard, klipper oder xcutsel, können Daten zwischen diesen Puffern getauscht, verwaltet oder gespeichert werden.
Beim XTerm gibt es ein Menü, das sich öffnet, wenn man Strg und tertiäre Maustatse im Fenster gedrückt hält. Dort gibt es einen Menüpunkt "Select to Clipboard", welcher die Auswahl dann eben ins Clipboard, statt (nur?) der Primary-Selection, bringt.

Geht der Text über mehrere Bildschirm-Seiten, kann man i.d.R. nach oben scrollen und mit der primären Maustaste eine Auswahl beginnen. Dann scrollt man zu der Stelle, wo sie aufhören soll und erweitert die Auswahl durch die sekundäre Maustaste bis zur entsprechenden Position.

Wenn Du aber die Ausgabe eines Text-Programms sowiso als Datei brauchst, dann kannst Du, wie in "man bash" in der Sektion "REDIRECTION" unter "Redirecting Output", "Appending Redirected Output" und "Redirecting Standard Output and Standard Error" erklärt, in eine Datei umleiten. Also z.B. so:

Quellcode

1
programm &>ausgabe_und_fehler_textdatei


PS: Im Text-Modus von Linux (also z.B. auf einem "virtuellen Terminal") gibt es den "gpm", welcher ggf. dort die Textauswahl mit der Maus ermöglicht. Dort sind aber die Tasten evtl. anders belegt.
Außerdem kommt es auch immer auf die individuelle Programmierung an: Einige Programme unterstützen sowas gar nicht, wieder andere haben spezielle Tasten-Kombinationen für diese Funktionalitäten (z.B. links2 -> Shift+Maustaste für Auswahl).

//edit: Code-Tags sind besser als Anführungszeichen.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »oziris« (31.01.2009, 20:35)


5

01.02.2009, 13:03

Hi Leute !

Danke für die Tips das Kopieren klappt jetzt Wunderbar.
Ich boote jetzt von einem in Fat32 Formatieren USB-Stick

Hier nochmal fdisk -l


dev/sda: 8086 MByte, 8086617600 Byte
255 Köpfe, 63 Sektoren/Spuren, 983 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes

Gerät boot. Anfang Ende Blöcke Id System
/dev/sda1 * 1 984 7897056 b W95 FAT32
Partition 1 hat unterschiedliche phys./log. Enden:
phys=(982, 254, 63) logisch=(983, 36, 12)
/


Hier fdisk -l mit su eingabe

/dev/hda: 40.0 GByte, 40007761920 Byte
16 Köpfe, 63 Sektoren/Spuren, 77520 Zylinder
Einheiten = Zylinder von 1008 × 512 = 516096 Bytes

Gerät boot. Anfang Ende Blöcke Id System

Platte /dev/sda: 8086 MByte, 8086617600 Byte
255 Köpfe, 63 Sektoren/Spuren, 983 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes

Gerät boot. Anfang Ende Blöcke Id System
/dev/sda1 * 1 984 7897056 b W95 FAT32
Partition 1 hat unterschiedliche phys./log. Enden:
phys=(982, 254, 63) logisch=(983, 36, 12)


Ich muss ja auf /dev/hda zugreifen aber da kommt der besagte Fehler:

Laufwerk kann nicht eingebunden werden.
Die Fehlermeldung lautet:
mount: I could not determine the filesystem type, and none was specified

Wie soll ich vor gehen ?

Danke MFG Popey

linuxerr

Prof. Dr. Schlaumeier

  • »linuxerr« ist männlich

Beiträge: 8 557

Wohnort: Mecklenburg, zur Entwicklungshilfe in Chemnitz/Sachsen ;-)

  • Nachricht senden

6

01.02.2009, 14:32

also
1. ist die partitionstabelle fehlerhaft, die win95-partition hat mehr cylinder, als auf der platte überhaupt zu verfügung stehen.
2. wird sich aif der platte wohl kein (bekanntes) dateisystem befinden.

wenn du auf eventuell auf der platte befindliche daten pfeifen kannst, dann lösch die partition und leg eine neue an.
das geht mit fdisk!
wichtig ist, ob das eine linuxpartition oder eine win/dos-partition werden soll. willst du nur mit linux auf die partition zugreifen?

wenn ja, mach


su .......

fdisk /dev/sda


in fdisk kannst du mit p die partitionsdaten anzeugen lassen,
mit d kannst du partitionen löschen,
mit n kannst du neue partitionen anlegen,
mit t den partitionstyp ändern (standard ist eine linux-partition 83)
erst wenn du fdisk mit w beendest, werden die neuen partitionsdaten auf die platte geschrieben.

ein neue filesystem legst du zb mit
mkfs.ext2 /dev/sda1
in der partition sda1 an
Die Rechtschreibfehler in diesem Beitrag sind nicht urheberrechtlich geschützt.
Jeder der einen findet darf ihn behalten und in eigenen Werken weiterverwenden.

7

01.02.2009, 15:21

Zitat

Original von Popey
Die Fehlermeldung lautet:
mount: I could not determine the filesystem type, and none was specified

Wie soll ich vor gehen ?

Mit mount bindet man ja quasi ein Dateisystem ins System ein (siehe auch "man mount"). Dazu muss mount wissen, um welches Dateisystem es sich handelt. Wie man unschwer an der Fehlermeldung erkennen kann, gelang es nicht, das Dateisystem des Datenträgers zu bestimmen. Das kann mehrere Gründe haben:
  • Dateisystem defekt
  • Dateisystem ist dem Kernel unbekannt (siehe /proc/filesystems)
  • Falsches Device-Node angegeben

Du hast im Prinzip folgende Möglichkeiten:
  • Partitionieren (z.B. mit cfdisk, fdisk, sfdisk oder (g)parted) und/oder Formatieren (z.B. mit mkfs)
  • Mit fsck gucken, ob das Dateisystem beschädigt ist
  • Als root ("su"/"sudo"?) mit "file -s /dev/hda" gucken, ob das Dateisystem vielleicht doch erkannt wird, evtl. in /proc/filesystems danach suchen, und es dann, gemäß "man mount", manuell, als Parameter beim Mounten anzugeben. (Klappt vermutlich aber nicht.)


PS: Mit den Befehelen "man" und "info" kannst Du das Handbuch zu einigen genannten Befehlen abrufen.

8

01.02.2009, 16:44

[Gelöst]

Hi Leute !

Ihr seid klasse !

Mein Problem war unter anderen auch das ich su vergessen habe, mit su habe ich jetzt cfdisk ausgeführt und die Festplatte Formatiert.

Jetzt ist die Platte auch eingebunden.

Vielen Dank

MFG Popey

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Popey« (01.02.2009, 16:51)


Thema bewerten