Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Linux Forum Linux-Web.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

18.12.2007, 11:45

Grafikkarte wird nicht angezeigt

Hi,

auch ich bin Neuling:crazy: auf dem Gebiet Linux. Und natürlich habe ich da ein Problem...

Ich nutze OpenSuse 10.3 und möchte damit gern zwei unterschiedliche Bildschirme betreiben. Dafür habe ich zwei Grafikkarten eingebaut:

(AGP) Geforce4 MX 440SE with AGP8X
(PCI) Matrox Millenium (MGA 2064W)

Beide tauchen in den Hardware-Informationen auf, allerdings finde ich unter SaX2 nur die Matrox und kann dementsprechend keinen Multiscreen einrichten.

Beim Hoch-/Runterfahren oder im Textmodus seh allerdings alles auf dem Bildschirm der zur Geforce gehört.

Ich habe auch schon das Netz durchsucht, hab aber das Problem nicht lösen können. Es wäre klasse, wenn mir jemand helfen könnte.

2

18.12.2007, 12:07

Ist vollkommen logisch.


Man kann nicht zwei Grafikkarten betreiben, wenn sie an unterschiedlichen Slot Typen haengen.
Entweder du besorgst dir noch eine pci grafikkarte oder du belaesst es bei einem bildschirm...

3

18.12.2007, 12:14

Oder du kaufst dir eine GraKa, die 2 Anschluesse hat und Dual-Head out of the box unterstuetzt.
for Windows problems: reboot
for Linux problems: be root

4

18.12.2007, 14:10

Echt??

Echt? Es gibt' keine Möglichkeit, diese Anordnung, die ja unter Windows einwandfrei funktioniert, auch unter Linux zu betreiben?

Schade...

strcat

Unix Gladiator

  • »strcat« ist männlich

Beiträge: 2 330

Wohnort: /Earth/Germany/Bavaria/Regensburg

  • Nachricht senden

5

18.12.2007, 15:19

Zitat

Original von pi
Man kann nicht zwei Grafikkarten betreiben, wenn sie an unterschiedlichen Slot Typen haengen.

Waer mir neu das sowas nicht funktioniert. Mit XFree86 gab es bei mir damals auf jeden Fall keine Probleme (Xorg hab ich aufgrund fehlender Hardware noch nicht ausprobiert). Alte SGI-Kisten zicken nur rum wenn man die PCI-Karte nicht direkt neben dem AGP-Slot einsteckt, aber sonst..
Ob das AGP oder PCI ist, interessiert den X-Server relativ wenig, da er lediglich die BUS-ID in der Sektion "Device" der Konfigurationsdatei abarbeitet.
Christian 'strcat' Schneider <http://www.strcat.de/>
/* When all else fails, read the instructions. */

6

18.12.2007, 16:51

@strcat:
Also, ich hatte das mal auf einem (alten) PC ausprobiert und das BIOS konnte nicht auf beide Grafikkarten gleichzeitig zugreifen.
Ich schaetze mal, dass dein System neuer ist...

strcat

Unix Gladiator

  • »strcat« ist männlich

Beiträge: 2 330

Wohnort: /Earth/Germany/Bavaria/Regensburg

  • Nachricht senden

7

18.12.2007, 16:59

Zitat

Original von piIch schaetze mal, dass dein System neuer ist...

Ich hab das ~1997 mal mit XFree86 ausprobiert und da hat es funktioniert. Es gibt auch nichts das dagegen spricht. Beim OP werden beide Karten erkannt; also mit lspci(8) die BUS-ID der Karten raussuchen, in der xorg.conf angeben und dann funktioniert es.
Christian 'strcat' Schneider <http://www.strcat.de/>
/* When all else fails, read the instructions. */

linuxerr

Prof. Dr. Schlaumeier

  • »linuxerr« ist männlich

Beiträge: 8 557

Wohnort: Mecklenburg, zur Entwicklungshilfe in Chemnitz/Sachsen ;-)

  • Nachricht senden

8

18.12.2007, 17:29

Zitat

Original von pi
@strcat:
Also, ich hatte das mal auf einem (alten) PC ausprobiert und das BIOS konnte nicht auf beide Grafikkarten gleichzeitig zugreifen.
Ich schaetze mal, dass dein System neuer ist...


ob das bios auf beide karten schreiben kann ist doch unerheblich. das bios wird in den meisten fällen auf die karte ausgeben, die im bios-setup angegeben ist (auswahl on-board,agp.pci).
ob die konfiguration mit sax geht kann ich nicht sagen, dass es geht, wenn man die xorg.conf von hand ändert, da kann ich strcat nur zustimmen.
Die Rechtschreibfehler in diesem Beitrag sind nicht urheberrechtlich geschützt.
Jeder der einen findet darf ihn behalten und in eigenen Werken weiterverwenden.

9

18.12.2007, 19:56

@linuxerr


tja, gut aber der alte PC war ein W98er.

Wie dem auch sei, also es kommt aufs os an.

linuxerr

Prof. Dr. Schlaumeier

  • »linuxerr« ist männlich

Beiträge: 8 557

Wohnort: Mecklenburg, zur Entwicklungshilfe in Chemnitz/Sachsen ;-)

  • Nachricht senden

10

18.12.2007, 20:18

Zitat

Original von pi
tja, gut aber der alte PC war ein W98er.

was ist ein w98er pc?

Zitat

Wie dem auch sei, also es kommt aufs os an.

ja und im X geht es definitiv, auch mit karten mit unterschiedlichen bussystemen.
Die Rechtschreibfehler in diesem Beitrag sind nicht urheberrechtlich geschützt.
Jeder der einen findet darf ihn behalten und in eigenen Werken weiterverwenden.

Thema bewerten