Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: Linux Forum Linux-Web.de. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

1

18.07.2006, 13:32

Problem mit Screen blank unter X?

Hallo,

seit neuestem habe ich das Problem, dass mein Bildschirm nach ein paar Minuten untätigkeit am Rechner dem Bildschirm auf "blank" schaltet.

Ich nutze KDE 3.5.3-0.4.fc5 und Kernel: 2.6.17-1.2157_FC5-i686.
Als GraKa-Treiber nutze ich kmod-fglrx zum passenden Kernel.

Das selbe Problem habe ich jedoch auch, wenn ich nur den "radeon"-Treiber in meiner xorg.conf angebe.

unter kcontrol habe ich nichts weiter gefunden, was mir den Monitor auf "blank" setzen könnte. Habe auch schon versucht die Energiesparoptionen des Monitors ab zu schalten sowie ein zu schalten und alle 3 Regler auf deaktiviert zu setzen. Alles ohne Erfolg :(

Um es genauer zu Beschreiben, es kommt mir so vor als ob der "Screensaver" von der Console auf mein X zugreift.

Wie kann ich das abstellen?
Bin für jeden Tipp dankbar.

Grüße,
TiDschay

linuxerr

Prof. Dr. Schlaumeier

  • »linuxerr« ist männlich

Beiträge: 8 557

Wohnort: Mecklenburg, zur Entwicklungshilfe in Chemnitz/Sachsen ;-)

  • Nachricht senden

2

18.07.2006, 15:11

RE: Problem mit Screen blank unter X?

oder du hast
im bios im powermanagenment die screensaver funktion aktiviert
oder im X einen screensaver geladen.
Die Rechtschreibfehler in diesem Beitrag sind nicht urheberrechtlich geschützt.
Jeder der einen findet darf ihn behalten und in eigenen Werken weiterverwenden.

3

19.07.2006, 09:11

RE: Problem mit Screen blank unter X?

Hallo linuxerr,

habe gestern den ganzen Tag nochmals versucht das irgendwie hinzubekommen.

Also ich kann jetzt schon sagen, am Bios liegt es nicht dort sind alle Stromsparmasnamen abgeschaltet. Einen Screensaver kann ich dort nicht einstellen.
Als Screensaver unter KDE nutze ich Qix, welcher auf nicht automatisch starten steht, um den Bildschirm nur dann zu sperren, wenn ich das möchte.

Selbst wenn ich den Bildschirm sperre und der Screensaver läuft, dauert es nicht lange und schon ist der Bildschirm schwarz.

Einen anderen Bildschirmschoner habe ich auch schon versucht, mit dem selben Ergebnis.

Habe auch den fglrx-Treiber abgeschaltet und nur noch den "radeon"-Treiber laufen, mit dem Ergebnis: keine Besserung, alles wie gehabt, der Bildschirm wird schwarz.

Danke,
TiDschay

4

19.07.2006, 16:10

[gelöst] Problem mit Screen blank unter X?

Hallo,

hab den Fehler gefunden.
Es war der fglrx-Treiber. Meine Radeon 9200 wird durch kmod-fglrx nicht mehr unterstützt. Hierdurch gab es auch noch ein paar andere Probleme.

Es musste eine Datei des neuen fglrx mit einer aus einem alten Packet ausgetauscht werden und schon lief es wieder.

Danke trotzdem für die Info,
TiDschay

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »TiDschay« (19.07.2006, 16:11)


5

12.01.2007, 18:57

Hallo TIDschay,

ich habe ein ähnliches Problem: Blank screen nach ein paar Minuten Wartezeit mit Widescreen-Monitor an einer Radeon 9250. Vielleicht kannst du mal genau mitteilen,
welche Datei du ausgetauscht hast, damit ich das Problem auch beheben kann.

Viele Grüße
TOWER

linuxerr

Prof. Dr. Schlaumeier

  • »linuxerr« ist männlich

Beiträge: 8 557

Wohnort: Mecklenburg, zur Entwicklungshilfe in Chemnitz/Sachsen ;-)

  • Nachricht senden

6

13.01.2007, 18:51

@tower

so ist das leider. einige leute sind pure egoisten und verwechseln ein forum mit einer support-hotline oder einem selbstbedienungsladen. sie erwarten hilfe, geben aber selbst keine. IHR problem ist ja GELÖST und was gehen mich die ANDEREN an.
beim nächsten problem, dass sie posten wundern sie sich dann, dass sie ruppig angefasst werden oder keine antwort mehr erhalten.
Die Rechtschreibfehler in diesem Beitrag sind nicht urheberrechtlich geschützt.
Jeder der einen findet darf ihn behalten und in eigenen Werken weiterverwenden.

7

14.01.2007, 01:41

Hallo,

@linuxerr: hast Du vieleicht auch mal daran gedacht, dass es Tage gibt, an welchen jemand nicht nach E-Mails schaut und es deshalb auch mal ein oder zwei Tage dauern könnte?
Nachdem wir hier Familienzuwachs bekommen haben, spielt der PC nun mal eine etwas weniger wichtige Rolle für mich!
Ach und noch eine Möglichkeit gibt es da, dass man das Beobachten eines Threads auch abscahlten kann, kennst Du sicherlich auch oder?

@Tower: Leider kenne ich mich mit der Radeon 9250 nicht aus. Habe aber hier im Forum unter dem Thread: http://www.linux-web.de/thread.php?threa…ilightuser=8513
ein kleines Workaround gepostet. Ich hoffe, dass Dir das helfen kann, hoffe aber auch auf der anderen Seite, dass ATI inzwischen das Problem von sich aus gelöst hat.

Ansonsten habe ich in der Datei /etc/X11/xorg.conf einfach das dpms auf off gestellt, beziehungsweise mit einer "#" vor der Zeile abgeschaltet.

... und nur so nebenbei, nachdem ATI veröffentlicht hat, dass meine Radeon in Zukunft nicht mehr von den Linuxtreibern unterstützt wird, habe ich zu einem anderen GraKa Hersteller gewechselt.

Grüße,
TiDschay

linuxerr

Prof. Dr. Schlaumeier

  • »linuxerr« ist männlich

Beiträge: 8 557

Wohnort: Mecklenburg, zur Entwicklungshilfe in Chemnitz/Sachsen ;-)

  • Nachricht senden

8

14.01.2007, 16:28

Zitat

Original von TiDschay
Hallo,

@linuxerr: hast Du vieleicht auch mal daran gedacht, dass es Tage gibt, an welchen jemand nicht nach E-Mails schaut und es deshalb auch mal ein oder zwei Tage dauern könnte?
Nachdem wir hier Familienzuwachs bekommen haben, spielt der PC nun mal eine etwas weniger wichtige Rolle für mich!

ok, akzeptiert.
ich bin davon ausgegangen, dass man den hinweis auf die lösung ja in seinem letzten posting kurz darstellen kann.

Zitat

Ach und noch eine Möglichkeit gibt es da, dass man das Beobachten eines Threads auch abscahlten kann, kennst Du sicherlich auch oder?

kenne ich, sollte man als mod aber nicht benutzen :)

Zitat

@Tower: Leider kenne ich mich mit der Radeon 9250 nicht aus. Habe aber hier im Forum unter dem Thread: http://www.linux-web.de/thread.php?threa…ilightuser=8513
ein kleines Workaround gepostet. Ich hoffe, dass Dir das helfen kann, hoffe aber auch auf der anderen Seite, dass ATI inzwischen das Problem von sich aus gelöst hat.

dpms auf off sollte die entscheidende einstellung sein.
Die Rechtschreibfehler in diesem Beitrag sind nicht urheberrechtlich geschützt.
Jeder der einen findet darf ihn behalten und in eigenen Werken weiterverwenden.

Thema bewerten