Sie sind nicht angemeldet.

1

07.02.2006, 00:02

VServer Routing

Hallo zusammen

Ich bringe meinen VServer nicht an's Internet. Im LAN kann ich die anderen IPs pingen und auch von den anderen PC den VServer. Beim Ping auf den VServer bekomme ich allerdings keine Antwort. Entweder kommt wohl der Router nicht mit dem VServer zurecht, oder NAT macht irgendwie Proble, oder ich muss irgendwie Routen setzen.

Hat jemand von euch erfahrung mit VServern und kann mir da weiterhelfen?

Gruss

linuxerr

Prof. Dr. Schlaumeier

  • »linuxerr« ist männlich

Beiträge: 8 557

Wohnort: Mecklenburg, zur Entwicklungshilfe in Chemnitz/Sachsen ;-)

  • Nachricht senden

2

07.02.2006, 08:41

RE: VServer Routing

ohne die genaue netzwerkstruktur zu kennen ist es etwas schwierig darauf zu antworten. wenn ein router mit der router_ip die verbindung zum internet herstellt, dann muss auf dem rechner auf jeden fall eine defaultroute dort hin gesetzt werden.
zb mit:
route add default gw router_ip und eventuell könnte es noch notwendig sein einen nameserver einzutragen, zb in die resolv.conf
nameserver nameserver_ip
Die Rechtschreibfehler in diesem Beitrag sind nicht urheberrechtlich geschützt.
Jeder der einen findet darf ihn behalten und in eigenen Werken weiterverwenden.

3

13.02.2006, 11:13

RE: VServer Routing

Hallo

Ich habe nun vorerst ein IPCop zwischen Server und Modem geschaltet und so funktioniert es. Den SMC Router habe ich gemüllt. An den Routen sollte es eigentlich nicht liegen, die sollten stimmen.

Wahrscheinlich muss da noch was mit DNAT, SNAT, gemacht werden. Ich werde das bei Gelegenheit mal noch genauer anschauen. Es läuft ja nun, nicht ganz wunschgemäss, aber für den Moment ist es gut.

Gruss

Thema bewerten